1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

One shot to get it right

Discussion in 'Wrangler YJ (1986-1995)' started by scharkmaefer, Apr 27, 2019.

  1. Apr 27, 2019 at 9:24 AM
    #1
    scharkmaefer

    scharkmaefer [OP] New Member

    Joined:
    Apr 27, 2019
    Member:
    #3133
    Messages:
    1
    92 yj runs like complete scrap when it's cold and when it warms up(weather) it runs way better .b.but still like em running out of gas . Not one mechanic say the same thing. MAP sensor? Pressure regulator? If I had my way I replace it all. But I gotta get this right. Anyone have this issue
     
  2. Apr 27, 2019 at 9:46 AM
    #2
    Awrench

    Awrench Well-Known Member

    Joined:
    May 12, 2018
    Member:
    #2303
    Messages:
    569
    Gender:
    Male
    Vehicle:
    3 jeeps
    Jeeps are pretty easy to work, but with any vehicle the secret is -
     
    aggrex and TJ_abuser like this.
  3. Apr 27, 2019 at 10:03 AM
    #3
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,808
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Welcome @scharkmaefer ....some additional details about the YJ could help zero in on the issue(s)
     
  4. Apr 27, 2019 at 5:27 PM
    #4
    TJ_abuser

    TJ_abuser Well-Known Member

    Joined:
    Sep 18, 2018
    Member:
    #2590
    Messages:
    990
    First Name:
    Todd
    Vehicle:
    2005 jeep unlimited
    2 inch lift, bumper and winch 33" mud claw
    Is what @Awrench the secret is what where the last page of this book? Lol
     
    aggrex likes this.
  5. Apr 27, 2019 at 5:46 PM
    #5
    Jim Beam

    Jim Beam Well-Known Member

    Joined:
    Feb 11, 2019
    Member:
    #2891
    Messages:
    155
    Gender:
    Male
    First Name:
    Donald
    Vehicle:
    1986 CJ7
    Fuel Injection, Dana 44s, T18, 4.10s w/lockers
    When your engine is cold it is in an "open loop mode", some of your sensors are not operating or operating in a cold engine mode. As it warms up it goes into a "closed loop", meaning of the sensors should be functioning correctly. It can be an electrical issue also. Check for any engine codes of course.
     
  6. Apr 27, 2019 at 6:46 PM
    #6
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,808
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
     
    boondoc89 likes this.
To Top