1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Saying Hi

Discussion in 'New Member Introductions' started by Jrgabriel, Jul 14, 2019.

  1. Sep 14, 2019 at 7:29 PM
    #61
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,648
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Yes.....you can go take your shit back. I'd bring the title also. But yes.....you can take it from them. They are obviously incompetent. And have no idea what their doing. And I'd find out who the owner is. And call him/them out for an explanation. 2 plus months.....REALLY.....

    Ps. If they refuse to give you your keys back. Call the local Cops....And tv station....At least the Cops. Bring them with you.
     
  2. Oct 19, 2019 at 8:08 PM
    #62
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Car has now been there 4 months. I’m still in the loaner. Service manager was let go a couple weeks ago and apparently my ticket was closed out...so it’s been sitting up there for weeks not being worked on! Craziness!!! GM could only apologize but this still makes no sense at all!!!
     
  3. Oct 19, 2019 at 9:02 PM
    #63
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,308
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Incredible patience on your part. As mentioned many times you need to consult legal assistance asap
     
  4. Nov 6, 2019 at 3:45 PM
    #64
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    ok - so I got the Jeep back last Saturday. Engine light hasn’t gone back on yet but it is still acting rough though at that 65-70 spot. Sometimes it’s around that 60 mph spot...other times it is riding smooth. When I say rough I mean it feels a little like maybe the spark plug is missing or shaking a little bit. It’s noticeable but other times it feels like it will go smooth through these speeds. Really weird. What can that be? A spark plug? I believe it’s right at that 1600 rpm spot...maybe 1700 sometimes and going anywhere around 60-75. Another strange occurrence happening again are the windows going down when tuning off the car and lights flashing. This happened a few months ago when I first got the car and I changed the batteries in the key fob. What is going on? Any thoughts or ideas? Tomorrow I am supposed to be going back and taking the service manager for a drive. He claims he did drive it and it was running fine between those speeds....but I know enough to know that it isn’t right/perfect.
     
    JKBob 25 and aggrex like this.
  5. Nov 6, 2019 at 3:49 PM
    #65
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Btw - the fix this last time was to replace the sensor again. That makes 4 times. Come on really??
     
  6. Nov 6, 2019 at 4:05 PM
    #66
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,308
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Perhaps after they get it closer to making it run sort of right....trade it in and cut your losses? Work up a super discounted deal at a Jeep dealer desperate to make a sale ?
     
    JKBob 25 likes this.
  7. Nov 6, 2019 at 4:25 PM
    #67
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I really think it’s something minor still...but who knows. Why the heck would the windows go down like that after cutting off the engine? I replaced that battery about 4 months ago and haven’t even been using that key.
     
  8. Nov 6, 2019 at 4:35 PM
    #68
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I don’t
    I don’t really know what to do. I bought/financed this vehicle and it was $16,000. I don’t really have money to play games....but maybe you are right. I just want this one to work!!
     
    JKBob 25 likes this.
  9. Nov 6, 2019 at 5:14 PM
    #69
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,308
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    When Jeep shopping in 2016 the local Jeep dealer offered 7K for my trade. Drove over to local CARMAX (no obligation) and got 10K check in 20 minutes. Called the local Jeep dealer to cancel my tentative deal at the local dealer and drove 110+ miles one-way for a bigger discount off invoice.......Try a no obligation evaluation at CARMAX ....however YMMV
     
    JKBob 25 likes this.
  10. Nov 6, 2019 at 7:14 PM
    #70
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I hear ya
    .
    I hear ya. I just really feel like this one can be good if given the proper attention. It seems like I just got a bad service manager but I really don’t know. It is easy to say trade it in but I have a lot invested in getting this one.
     
  11. Nov 13, 2019 at 9:45 PM
    #71
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Got the car back today. They replaced the spark plugs this time. They test drove and say all is good with engine and attributing the intermittent shake to tire shimmy...

    thoughts??
     
  12. Nov 13, 2019 at 10:12 PM
    #72
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Here is a question - they didn’t replace any spark plug wires. I’ve looked and this doesn’t look like the wires I’m familiar with. When plugs are replaced and tuneup done...are wires supposed to be replaced too?
     
  13. Nov 16, 2019 at 8:56 PM
    #73
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Engine light back on! I cannot believe this crap.
     
  14. Nov 16, 2019 at 8:56 PM
    #74
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Engine light back on. I cannot believe this crap!
     
  15. Nov 16, 2019 at 9:02 PM
    #75
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,308
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Stop by local Advance/Autozone for a scan of the CEL. Post the results
     
  16. Nov 16, 2019 at 9:10 PM
    #76
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I really don’t want to bring it back to this dealership...but I have been speaking to the GM and they are providing me with loaners and doing all this for free. I’m just sick of this back and forth. To me it seems like a problem with spark plugs (but they changed those). Maybe it’s the timing?
     
  17. Nov 16, 2019 at 9:13 PM
    #77
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    One thing I am noticing is...they keep replacing those sensors and give it back to me and a week or two later (200-400 miles) the engine light is going back on.
     
  18. Nov 16, 2019 at 9:13 PM
    #78
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,308
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    If you suspect the spark plugs have someone inspect the wires too
     
  19. Nov 16, 2019 at 9:14 PM
    #79
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I would thought they would have done that when doing all this work. Maybe not.
     
  20. Nov 17, 2019 at 7:31 AM
    #80
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    96
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    After a little research...I’m thinking Tone Ring/Reluctor might be the culprit. My other thoughts are that it is the Alternator/Battery (Not certain if this could cause my problem)??
    What would keep causing that sensor to go bad and then to replace...me drive it 200-400 miles and problem all over again? How much would it cost to replace? Thoughts on next steps?
     
To Top