1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

02 heater circuit problems

Discussion in 'Wrangler JK (2007-2017)' started by jeepster2, Jun 17, 2017.

  1. Jun 17, 2017 at 5:07 PM
    #1
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    Has anyone had problems with all 4 heater circuits have permanent code for low voltage Thanks
     
  2. Jun 17, 2017 at 9:52 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Welcome! Whats the code being thrown, and can you give more information on what year, make and model?
     
  3. Jun 17, 2017 at 10:13 PM
    #3
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    Thanks it a 2011 jeep wrangler 70 th anniversary with 60.000 miles 3.8 the codes are p0031-p0037-p0051-p0057 all for sensors low circuit , I cannot find any fuse or relays all 4 sensors were replaced codes still there Engine lite still on ...thanks for you help.
     
  4. Jun 17, 2017 at 10:32 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Well....the good news is it should be covered under the Emissions Warranty, wich is 8 years/80,000 miles. Most cases are fixed with a new PCM. Might want to hit your dealer up for this one.
     
  5. Jun 17, 2017 at 10:36 PM
    #5
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    They told me that's not the case Warranty is out of date they claim the emission warranty is only good for the catalyst's not for any sensors or pcm problem ..
     
  6. Jun 18, 2017 at 10:13 AM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Might want to call their corporate office, or check another dealer.
     
    JKBob 25 likes this.
  7. Jul 7, 2017 at 10:36 AM
    #7
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    Would rather find diagnostic steps to find problem on my own ....Thanks
     
  8. Jul 7, 2017 at 11:52 AM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    I respect that. Thing is, most first steps are the sensors, then the PCM, which is an expensive item, and RE manufacture ones are 50/50 for working.
     
    JKBob 25 likes this.
  9. Jul 8, 2017 at 8:32 PM
    #9
    SmittyJeeper

    SmittyJeeper Well-Known Member

    Joined:
    Jun 24, 2017
    Member:
    #1601
    Messages:
    68
    Gender:
    Male
    Vehicle:
    06 wrangler 4.0 6speed
    5" lift, 4.11 gears, tru-trac limited-slips, winch, bumbers... you know the rest.
    The " totally integrated power module" are a pos in these new jeeps... parts made by the lowest bidder and all that. Do a 10 minute battery disconnect and see if the light comes back right away if it does is going to require a scan tool not a code reader.
     
  10. Jul 8, 2017 at 8:51 PM
    #10
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    Thanks for your reply . have you heard of problems with the integrated power modules , I did lift it out of its mount and checked it looks all clean under it at all the connections ..........Thanks again for any possible help
     
  11. Jul 8, 2017 at 8:53 PM
    #11
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    I Left the battery unhooked overnight came rite back on I think its to new to have wiring issues ,
     
  12. Jul 13, 2017 at 9:35 PM
    #12
    jeepster2

    jeepster2 [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1577
    Messages:
    8
    Gender:
    Male
    I finally solved the problem thanks guys it was the PCM got one from Flagship one for 217.00 dollars free shipping great company if any ever needs one comes fully programed with your vin and mileage and all 4 sensors I replaced were Delphi from rock auto for 110.00 dollars for set beats Chryslers at 110.00 each any day. no reoccurring codes and no engine lights good as new...
     
    JKBob 25 and chris4x4 like this.
  13. Jul 14, 2017 at 9:01 AM
    #13
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Great to hear!
     

Products Discussed in

To Top