1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

04 wrangler - loss of power

Discussion in 'Wrangler TJ (1996-2006)' started by jeepqueen, Jul 9, 2017.

  1. Jul 9, 2017 at 12:27 PM
    #1
    jeepqueen

    jeepqueen [OP] New Member

    Joined:
    Jul 9, 2017
    Member:
    #1660
    Messages:
    2
    Gender:
    Female
    First Name:
    Amy
    Vehicle:
    2004 jeep wrangler
    4.0 automatic
    Help! I have an 04 wrangler. 4.0 automatic. Was running fine until a sudden loss of power (engine light did come on). Replaced fuel pump with no results. Put diagnostic on and it threw codes for injection coils. Replaced coils and jeep started right up. Idles great - however as soon as you start to drive engine light comes and drastic loss of power. Was told to change 02 sensors, did that with no results. Any ideas/advice is greatly appreciated!

    Thanks
     
  2. Jul 9, 2017 at 12:46 PM
    #2
    SmittyJeeper

    SmittyJeeper Well-Known Member

    Joined:
    Jun 24, 2017
    Member:
    #1601
    Messages:
    68
    Gender:
    Male
    Vehicle:
    06 wrangler 4.0 6speed
    5" lift, 4.11 gears, tru-trac limited-slips, winch, bumbers... you know the rest.
    What are the codes?
     
  3. Jul 9, 2017 at 2:52 PM
    #3
    jeepqueen

    jeepqueen [OP] New Member

    Joined:
    Jul 9, 2017
    Member:
    #1660
    Messages:
    2
    Gender:
    Female
    First Name:
    Amy
    Vehicle:
    2004 jeep wrangler
    4.0 automatic
    Today it's P0352 - Ignition Coil 2 Circuit. Yesterday it showed P032,P0353,P0351 so I replaced the Ignition coils A,B,C (it's one part).
     
To Top