1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

1999 grand cherokee wont start

Discussion in 'New Member Introductions' started by Jeeper83, Jun 17, 2017.

  1. Jun 17, 2017 at 9:18 AM
    #1
    Jeeper83

    Jeeper83 [OP] New Member

    Joined:
    Jun 17, 2017
    Member:
    #1575
    Messages:
    3
    Gender:
    Male
    First Name:
    Jason
    Vehicle:
    1999 jepp grand cherokee
    None
    I turn the key and all lights work but wont start. Was thinking a starter or the ignition switch or tumbler. Is there anything else that it could be.
     
  2. Jun 17, 2017 at 7:48 PM
    #2
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,910
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Welcome! Any crank, click, spin, whirring, light dimming or dead silence? Community just needs more clues.
     
  3. Jun 17, 2017 at 8:06 PM
    #3
    Jeeper83

    Jeeper83 [OP] New Member

    Joined:
    Jun 17, 2017
    Member:
    #1575
    Messages:
    3
    Gender:
    Male
    First Name:
    Jason
    Vehicle:
    1999 jepp grand cherokee
    None
    Dead silence except when the starter/ignition fuse blows. I changed the starter/ignition fuse. Changed the ignition switch. After changing the ignition switch it continuously blows the starter/ignition fuse every time i turn it over. The dash lights work. Headlights work but also the windows will not roll up either. Im at a loss. I was think a direct short but i have no clue if im right or where it would be or where to start.
     
  4. Jun 17, 2017 at 8:38 PM
    #4
    OFFGRID

    OFFGRID Well-Known Member

    Joined:
    Oct 3, 2016
    Member:
    #317
    Messages:
    2,018
    Gender:
    Male
    First Name:
    Peter
    Houston
    Vehicle:
    1979 Jeep CJ7, 258, TH350, NP208
    Howell fuel injection, header, HEI distributor, TH350, NP208, SOA lift with YJ springs in the front & GW springs in the Rear. AMC20 with G2 1 piece chromos trussed, Dana 30 with G2 chromos and 760x ujoints and MM Stainless Hubs, Geared 4.56. Tom Woods shafts, Metal cloaks, Caged, 37" Toyo MTs.
    Could it be a loose or corroded ground from the battery to the block?
     
  5. Jun 17, 2017 at 8:39 PM
    #5
    Jeeper83

    Jeeper83 [OP] New Member

    Joined:
    Jun 17, 2017
    Member:
    #1575
    Messages:
    3
    Gender:
    Male
    First Name:
    Jason
    Vehicle:
    1999 jepp grand cherokee
    None
    Not sure but i will check that
     
To Top