1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2001 jeep cherokee limited will not start

Discussion in 'Cherokee' started by jim14424, Aug 22, 2016.

  1. Aug 22, 2016 at 7:49 AM
    #1
    jim14424

    jim14424 [OP] New Member

    Joined:
    Aug 22, 2016
    Member:
    #108
    Messages:
    1
    Gender:
    Male
    First Name:
    Jim
    Vehicle:
    2001 jeep cherokee limited
    none
    I have a 2001 Jeep Cherokee limited, that will crank but will not start. I have replaced the crankshaft position sensor, and the camshaft position sensor. I do have fuel getting to the engine, but no spark. I check the coil pack, but do not see spark. Its hard to believe that all would go bad at the same time. What else should I be checking?
     
  2. Aug 22, 2016 at 9:22 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,034
    Gender:
    Male
    Welcome!
    Check the Idle Air Intake Sensor.
     
  3. Aug 22, 2016 at 9:24 AM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,034
    Gender:
    Male
    I also found this:

    The most likely cause of it cranks and cranks but won't start up is the Crankshaft Position Sensor (CPS) located on the transmission bell housing. Often this part is also referred to as the CranKshaft Position Sensor (CKP) CPS/CKP failure is very common. The CPS/CKP can stop working with no warning or symptoms and the engine will not run or the engine may randomly stall for no apparent reason.

    Crank Position Sensors can have intermittent “thermal failure”. This means that the CPS/CKP fails when engine gets hot, but works again (and will test as “good”) when it cools back down.

    Begin with basic trouble shooting of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables or connectors and replace as needed. Do the same for the grounding wires from the starter to engine block, and from the battery and engine to the Jeep's frame/body. Jeeps do not tolerate low voltage or poor grounds and the ECM/ECU may behave oddly until you remedy this.



    Symptoms –

    - Starter cranks and cranks but engine won't start up and run.
    - Fuel gauge and voltage gauge may not work or display properly.
    - You sometimes will have No Bus on the odometer after 30-60 seconds.
    - A failed CPS/CKP may or may not throw a CEL trouble code.
    - No spark at the spark plugs.
    - Fuel pump should run and prime for 3-5 seconds.

    If the CPS/CKP is failed sometimes the OBD-II trouble code reader cannot make a connection to the ECU/computer or cannot read Check Engine Light/MIL codes because the CPS/CKP has failed. Disconnect the code reader, disconnect the CPS/CKP wire connector, and reconnect the code reader. If the code reader establishes contact with the ECU and scans, your CPS/CKP is failed and needs to be replaced.


    Diagnostic steps to confirm the CPS is the cause of your no-start


    You should be able to verify a bad cps, by unplugging it, and turning the ignition key to on. If the voltage gauge and/or the fuel gauge now displays correctly, replace the CPS.

    Unplugging and reconnecting the CPS sensor where it connect to the main harness near the back of the intake manifold usually resets the ECU and if the jeep fires right up after doing this you can bet that the CPS is faulty and needs to be replaced.

    Exchange the fuel pump relay and the ASD relay with one of the other similar ones in the PDC to eliminate the relays as the cause of the no-start. Confirm that the fuel pump to runs for 3-5 seconds when you turn the ignition key to ON.

    Eliminate the NSS as a cause of no start. Wiggle the shift lever at the same time you try to start. Put the transmission in Neutral and do the same. Do the reverse lights come on when the shifter is in Reverse?

    Inspect the wires and wire connectors at the O2 sensors on the exhausts pipe. A short circuit from melted insulation or from broken O2 sensor wires can blow a fuse and the ECU/ECM will loose communication. Don’t get tunnel vision and assume the sensor is bad (unless it tests bad with a meter). Damaged wiring or a dirty connector can inhibit the signal from making it to the computer. Inspect/test/clean/repair wiring or connectors as necessary.


    CPS Testing


    Crankshaft Position Sensor Connector (CPS/CKP)


    [​IMG]
    .
    [​IMG]


    TESTING PROCEDURE 1991 – 2001 4.0L H.O. engines

    1. Near the rear of intake manifold, disconnect sensor pigtail harness connector from main wiring harness.
    2. Place an ohmmeter across terminals B and C (See Image). Ohmmeter should be set to 1K-to-1OK scale for this test.
    3. The meter reading should be open (infinite resistance). Replace sensor if a low resistance is indicated.

    TESTING PROCECURE for 1987 – 1990 4.0 L engines

    Test # 1 - Get a volt/ohm meter and set it to read 0 - 500 ohms. Unplug the CPS and measure across the CPS connector's A & B leads. Your meter should show a CPS resistance of between 125 – 275 Ohms. . If the CPS is out of that range by much, replace it.

    Test # 2 - You'll need a helper for this one. Set the volt/ohm meter to read 0 - 5 AC volts or the closest AC Volts scale your meter has to this range. Measure across the CPS leads for voltage generated as your helper cranks the engine. (The engine can't fire up without the CPS connected but watch for moving parts just the same!) The meter should show .5 - .8 VAC when cranking. (That's between 1/2 and 1 volt AC.) If it's below .5vac, replace it.


    The 2000 and 2001 will have the CPS in the same location on the bell housing, but the wire connector may be on the passenger side, not as shown in the diagram below. Simply follow the wire from the sensor to the connector.

    .
    [​IMG]
     
    Bob likes this.
To Top