1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2002 4.0, Keep getting codes 302,304,306....a little help... Please...

Discussion in 'Wrangler TJ (1996-2006)' started by Bf2mitch, Nov 18, 2016.

  1. Nov 18, 2016 at 2:12 PM
    #1
    Bf2mitch

    Bf2mitch [OP] New Member

    Joined:
    Nov 18, 2016
    Member:
    #514
    Messages:
    1
    Gender:
    Male
    First Name:
    Doug
    Vehicle:
    2002 Wrangler X 4.0
    Okay, I've replaced the coil pack x2, crank sensor, put new plugs and it was fine until I hit 3100 RPMs at 74 mph (between 70-75) for about 25 miles and that it happen again. My jeep started acting like putting your hand over a vacuum hose then taking it off. I had to let off the throttle to stop the lack of power and then re-throttle to regain power. I dropped from 74ish to around 60mph and stayed at that speed until I got off the FWY. In town drove rough, and very low rough idle a stops. Same codes again keep coming up. 302,304,and 306. Any ideas? Thanks in advance.
     
  2. Jun 26, 2017 at 8:55 AM
    #2
    Pcchadwe

    Pcchadwe Member

    Joined:
    Jun 26, 2017
    Member:
    #1607
    Messages:
    11
    Gender:
    Male
    First Name:
    Phillip
    Vehicle:
    2005 TJ Rubicon
    4" lift, headers, stainless steal cat back system, 33" wheels, 9.5ti Warn winch, cold air induction, gel battery, crawler bumpers, lifted induction,
    Check the OPDA. That's the distributor for these TJs. You have replaced the plugs and the ignition rail so the oil pump drive assembly (camshaft position synchronizer) is all I know of that's left. Crowns are the best replacement. I got mine through Quadratec. Cleared it up. I was throwing 340, 344 and 301s. Camshaft position sensor intermittent failure and mis-fire on cyl 1. Hope this helps.
     
To Top