1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2003 jeep grand Cherokee loredo 4.0

Discussion in 'Grand Cherokee' started by Realtree1986, Sep 11, 2017.

  1. Sep 11, 2017 at 5:20 PM
    #1
    Realtree1986

    Realtree1986 [OP] New Member

    Joined:
    Sep 11, 2017
    Member:
    #1869
    Messages:
    1
    Gender:
    Male
    First Name:
    Travis
    Vehicle:
    2003 jeep grand Cherokee loredo
    Okay people I'm stumped on this one! So here it goes the other day I got a bump in the road. In result of that my blinkers and a.c. and heat all went out ? So here is what I did to acess the problem I replaced blinker relay fuse a.c. blower motor and climate relay sensor and still nothing no other fuse is blown that I can find. So I'm stumped does any have an answer that can help me figure this out?
     
  2. Sep 11, 2017 at 6:20 PM
    #2
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,970
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Challenging problem to diagnose online that could be related to a loose or bad ground or short in the wiring harness aggravating the electronics by impacts from the road.
     
    JKBob 25 likes this.
  3. Sep 14, 2017 at 4:02 PM
    #3
    2oldjeeps

    2oldjeeps Well-Known Member

    Joined:
    May 6, 2017
    Member:
    #1438
    Messages:
    154
    Gender:
    Male
    Vehicle:
    98 and 2000 xj's 99wj
    98 lifted, 00 stock 99wj just beautiful
    a haynes manual always helps me with electrical trouble. you gotta look at the wiring info.
     
    JKBob 25 likes this.
  4. Sep 14, 2017 at 6:58 PM
    #4
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Welcome to the forum.

    Agreed. Sounds like a wiring issue.

    The only experience I have with an issue similar to this. An Ex hit a bump so hard. It broke a battery terminal. And her JKU started acting like it was possessed. Turn signals worked on and off, ac the same. Would just shut down, and start right up. A big box auto repair couldn't find it. I started at ground zero. The battery. Bingo...If not the issue. Relays and fuses are a good place to start.
     
    aggrex likes this.
To Top