1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2007 JKU, no acceleration

Discussion in 'Wrangler JK (2007-2017)' started by eagleyes8108, Apr 18, 2017.

  1. Apr 18, 2017 at 2:25 PM
    #1
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    Hi , everyone .I'm new on this place. I have a question to whom might know the answer or at least give me and idea , it will be much appreciated. I have a 2007 jeep wrangler unlimited X a couple nites ago I left the lights on and battery died. when I jump start it next morning I turn on the jeep no problems but the Lighting light came on , no other lights but that one the problem is I step on the gas and notice there was no response. So I checked battery , fuses but nothing. Any ideas?? car was parked at my house , starts everytime but have no clue what could be .
     
  2. Apr 18, 2017 at 2:50 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Welcome to the site! Actually had this same thing happen to a friend recently and whn he bought a new battery, everything returned to normal.
     
  3. Apr 18, 2017 at 2:58 PM
    #3
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    I have bought a new battery but nothing. Thanks a lot tho
     
  4. Apr 18, 2017 at 10:19 PM
    #4
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    what that light means is loss of communication between throttle pedal and throttle body
     
  5. Apr 19, 2017 at 5:01 AM
    #5
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    I order pedal sensor and throttle position sensor from ebay. Hopefully will get it back running. Thankz everyone.
     
  6. Apr 19, 2017 at 5:47 AM
    #6
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    It should fix if you need more help let me know
     
    chris4x4 likes this.
  7. Apr 24, 2017 at 3:48 PM
    #7
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    Update: so i had throttle position sensor and pedal sensor replaced , got new battery......still lifhting light is on. No acceleration. Any ideas? Thank you
     
  8. Apr 24, 2017 at 7:56 PM
    #8
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    Are you fixing your self or a shop if you are fixing yourself do you have or borrow a scan tool need data from truck
     
  9. Apr 24, 2017 at 8:07 PM
    #9
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    Is there a check engine light on. Let me know I will keep looking for your ansers
     
  10. Apr 25, 2017 at 4:56 AM
    #10
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    No engine light , only the etc light. Im trying not to take it to a shop. But at this point I dont know what else to check or do
     
  11. Apr 25, 2017 at 5:33 AM
    #11
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    I do have a scanner,
     
  12. Apr 25, 2017 at 8:13 AM
    #12
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    can you see throttle pedal and tps signals do thay match at no pedal if thay match slowly increase if matches all the wy to wide open throttle disconnect both battery cables touch positive and negitive cables to each other hold cables together for a few minites like 5 reconnect and see if that helps let me know
     
  13. Apr 25, 2017 at 11:31 AM
    #13
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    I think that method only applies to throttle by wire applications. IIRC, the 2007 uses a cable to the throttle body?
     
  14. Apr 25, 2017 at 12:27 PM
    #14
    K6puppy

    K6puppy Well-Known Member

    Joined:
    Apr 8, 2017
    Member:
    #1309
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Arizonia
    Vehicle:
    2014 Jeep wrangler unlimited wellys wheeler Black
    xrc front bumper 12000 pound badlands winch 6 pod lights fender flares kc headlight 285/70/17 tires 2 inch leveling kit bushwhacker air snorkel k/N intake rough country duuel steering stabilizer kit
    I just looked all throttle body pics for 07 are drive by wire Is yours a cable actuated throttlebody or drive buy wire you said you replaced sensors or did you replace pedal and throttle body
     
  15. May 1, 2017 at 3:33 AM
    #15
    eagleyes8108

    eagleyes8108 [OP] Member

    Joined:
    Apr 18, 2017
    Member:
    #1366
    Messages:
    7
    Gender:
    Male
    First Name:
    Erick
    Vehicle:
    2007 JKU
    285/75/r16 tires , unique classic rims 16 8.5
    Hey guys, sorry for taking so long to answer.
    K6 : It is a pedal sensor yes the whole thing ( i ended up buying stuff i didnt need. Lesson learned.)Well here is the update:
    I decided to take it to a dealer because I read somewhere that computer needed to relearn the codes. They were going to take 2 weeks before seeing my jeep. But lucky me i had a friend that knows a friend. So i took it and he fix it in like 30 minutes or less. Dealer was going to charge me $380, the guy charged me $100 so I happily paid him.
    Thanks to everyone for your help. Hope this helps someone in the future.
     
  16. May 1, 2017 at 6:50 AM
    #16
    OFFGRID

    OFFGRID Well-Known Member

    Joined:
    Oct 3, 2016
    Member:
    #317
    Messages:
    2,018
    Gender:
    Male
    First Name:
    Peter
    Houston
    Vehicle:
    1979 Jeep CJ7, 258, TH350, NP208
    Howell fuel injection, header, HEI distributor, TH350, NP208, SOA lift with YJ springs in the front & GW springs in the Rear. AMC20 with G2 1 piece chromos trussed, Dana 30 with G2 chromos and 760x ujoints and MM Stainless Hubs, Geared 4.56. Tom Woods shafts, Metal cloaks, Caged, 37" Toyo MTs.
    Wonderful glad you fixed it. So if I understand you correctly you just had to flash your computer?
     

Products Discussed in

To Top