1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2010 Jeep Commander won't reverse or go over 12mph

Discussion in 'Other Jeep Vehicles' started by Dano5160, Nov 3, 2017.

  1. Nov 3, 2017 at 8:38 AM
    #1
    Dano5160

    Dano5160 [OP] New Member

    Joined:
    Nov 3, 2017
    Member:
    #1974
    Messages:
    2
    Gender:
    Male
    First Name:
    Dano
    Vehicle:
    2010 Jeep commander
    I have a 2010 Jeep commander. I did a 30 mile rd trip. Stopped at McDonald's Drive thru to get a meal. Went to pull out of McDonald's. Jeep started vibrating/shaking and wouldn't go no faster than 45 MPH. I pulled over to the side of the road. Put it in reverse.No Reverse. I then attempted to drive it home because,i was stuck in know where land. Now it wont go faster than 12 MPH. All the Dash warning lights are stuck on. No Reverse and seems to be stuck in limp mode. What's wrong with this Jeep?
    Thanks!
     
  2. Nov 3, 2017 at 9:49 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Welcome to the site! Can you have the diagnostic codes read, and post them?
     
    JKBob 25 likes this.
  3. Nov 3, 2017 at 12:13 PM
    #3
    Dano5160

    Dano5160 [OP] New Member

    Joined:
    Nov 3, 2017
    Member:
    #1974
    Messages:
    2
    Gender:
    Male
    First Name:
    Dano
    Vehicle:
    2010 Jeep commander
    Don't have a code reader. Every warning lite is on. No reverse. Limp mode. Can't even check the tranny fluid in it.No dip stick.
     
  4. Nov 3, 2017 at 5:29 PM
    #4
    Bob

    Bob Well-Known Member Moderator

    Joined:
    Jul 18, 2016
    Member:
    #1
    Messages:
    617
    Gender:
    Male
    AutoZone will read your codes for free
     
    aggrex, JKBob 25 and chris4x4 like this.
  5. Nov 3, 2017 at 6:51 PM
    #5
    Offroad798

    Offroad798 Well-Known Member

    Joined:
    Oct 2, 2017
    Member:
    #1927
    Messages:
    195
    Gender:
    Male
    First Name:
    Bob
    Florida
    Vehicle:
    2015 Rubicon
    fenders, bumpers, winch, inner fenders, cb, headliner storage, oil pan armor
    Welcome from Florida. I agree with Bob get codes first to narrow you problem.
     
    JKBob 25 likes this.
  6. Nov 3, 2017 at 7:12 PM
    #6
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Welcome to the forum Dano. Agree with previous posts. If you have warning lights. You have codes to be read. Get the codes and go from there. We have numerous members that are great with codes, and their fixes. Keep us posted.
     
  7. Nov 3, 2017 at 7:38 PM
    #7
    boondoc89

    boondoc89 Well-Known Member

    Joined:
    Feb 3, 2017
    Member:
    #912
    Messages:
    772
    Gender:
    Male
    First Name:
    alex
    Vehicle:
    08 JKU
    3 inch zone lift. Fox 2.0 shocks. 35 inch nitto ridge grapplers. Bushwacker flat fenders. No name steel bumpers front and back for now.
    Have you tried disconnecting the battery for a little while to let the CPU and stuff to restart?? My Chevy did that a few times and I just ended up trying that and it worked for a short amount of time. Enough time to get it figured out anyway. Might get it out of limp mode long enough to get it a place to read the codes it's throwing at ya
     
    chris4x4, aggrex and JKBob 25 like this.
To Top