1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2012 grand cherokee air/heat unit

Discussion in 'Grand Cherokee Marketplace' started by rong73, Sep 8, 2017.

  1. Sep 8, 2017 at 10:51 AM
    #1
    rong73

    rong73 [OP] New Member

    Joined:
    Sep 8, 2017
    Member:
    #1852
    Messages:
    4
    Gender:
    Male
    First Name:
    ron
    Vehicle:
    2012 grand cherokee laredo 4x4
    i have a 2012 grand cherokee laredo 4x4 and when i turn either the heat or AC the unit responds but no air is beinmg distrubited through the vents
     
  2. Sep 8, 2017 at 11:11 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Welcome! Sounds like the fan isn't working?
     
  3. Sep 8, 2017 at 2:16 PM
    #3
    Prerunner1982

    Prerunner1982 Well-Known Member

    Joined:
    Aug 4, 2017
    Member:
    #1745
    Messages:
    1,298
    Gender:
    Male
    First Name:
    Jon
    Vehicle:
    93 XJ 2 door
    Is it coming through the defrost vents instead or no vents at all?
     
  4. Sep 8, 2017 at 2:44 PM
    #4
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,970
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Is the blower motor functioning? Check the fuses? Without heat or a/c engaged is there any ventilation or recirculation?
     
  5. Sep 8, 2017 at 3:15 PM
    #5
    rong73

    rong73 [OP] New Member

    Joined:
    Sep 8, 2017
    Member:
    #1852
    Messages:
    4
    Gender:
    Male
    First Name:
    ron
    Vehicle:
    2012 grand cherokee laredo 4x4
    Not coming in through any vents at all!!
     
  6. Sep 8, 2017 at 3:16 PM
    #6
    rong73

    rong73 [OP] New Member

    Joined:
    Sep 8, 2017
    Member:
    #1852
    Messages:
    4
    Gender:
    Male
    First Name:
    ron
    Vehicle:
    2012 grand cherokee laredo 4x4
    I will check the fuses!!
     
  7. Sep 8, 2017 at 3:17 PM
    #7
    rong73

    rong73 [OP] New Member

    Joined:
    Sep 8, 2017
    Member:
    #1852
    Messages:
    4
    Gender:
    Male
    First Name:
    ron
    Vehicle:
    2012 grand cherokee laredo 4x4
    Nothing at all coming through vents.. checked fuses, all seem fine..
     
To Top