1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

97 Cherokee 5.2 Stalling At Idle-Intermittent Issue

Discussion in 'Cherokee' started by Mike iVan, Dec 4, 2016.

  1. Dec 4, 2016 at 9:35 AM
    #1
    Mike iVan

    Mike iVan [OP] New Member

    Joined:
    Nov 1, 2016
    Member:
    #436
    Messages:
    2
    Gender:
    Male
    First Name:
    Mike
    Vehicle:
    1997 Grand Cherokee
    Hoping someone can help. Have a strange issue with my Son's 1997 Grand Cherokee limited with the 5.2. Has 78000 miles, and when it runs, it runs GREAT! Problem is, he can drive it for a day or two with no problems, then it will start stalling at idle. Will start right back up, but when you let the throttle off, it dies. Replaced IAC, thought that fixed it, but problem came back in a couple days. Then I noticed when this happens, I can clear it up for a day or two by removing the battery cable, which I did when I replaced the IAC.

    Seems like the battery being removed fixes it. Also, the battery was dead from him turning it over I assumed, and when I jumped it (didn't charge, just jumped), ran fine for a 30 minute drive no stalling. Runs fine with battery disconnected, so shade tree test of alternator passes. One other thing I can think of is that the information center in the dash was throwing a coolant level alarm, which was not accurate, see this a lot with these as well. But recently the information center smoked and is no longer working.

    I see a lot of the same issues with these vehicles, and no one really seems to have a handle on what the issue is. Also, when I run my reader on it, the only code it throws is the battery disconnected recently code, which I expect. No other codes. Seems like a computer issue, but not sure. Also, I suspect if battery is failing could cause issues, but alternator seems to be keeping up when at idle, so not sure if battery is even in play at this point. Any help is appreciated.
     
  2. Dec 24, 2016 at 5:48 AM
    #2
    Mike iVan

    Mike iVan [OP] New Member

    Joined:
    Nov 1, 2016
    Member:
    #436
    Messages:
    2
    Gender:
    Male
    First Name:
    Mike
    Vehicle:
    1997 Grand Cherokee
    UPDATED: So after the IAC went ahead and swapped the TPS. Interesting, tested the old TPS with my Fluke ohm meter. Nothing glaring in the changes in resistance as I cranked the TPS. But when I put my meter on continuity check, I noticed that, in just about the same spot every time I rotated the throttle position sensor as if the accelerator is being depressed, there was a dead short in the TPS. I could not pick this up in OHM check mode, but the meter caught it in continuity check. Has been installed for 3 weeks now and no stalling.
     
    Paul123 and chris4x4 like this.
  3. Dec 24, 2016 at 12:51 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,415
    Gender:
    Male
    Thanks for the update!
     
  4. Dec 24, 2016 at 7:37 PM
    #4
    C2T

    C2T Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #42
    Messages:
    761
    Gender:
    Male
    First Name:
    Richard
    Helena, Montana
    Vehicle:
    Jeep
    2.5" AEV Dual Sport lift, 35" Treadwright Guard Dogs, Black Rock Wheels, AEV Front & Rear Bumpers with Tire Carrier, Fuel Caddy 10 gal. Aux. fuel tank, Warn 9.5ti, 125' synthetic winch line, front axle skid, 20" LED light bar , Bilstein Shocks, steel steering skidplate,
    So your got the issue fixed? am I reading that correctly?
     

Products Discussed in

To Top