1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

AZC bad?

Discussion in 'Grand Cherokee' started by glassport, May 23, 2020.

  1. May 23, 2020 at 3:17 PM
    #1
    glassport

    glassport [OP] Member

    Joined:
    Mar 15, 2019
    Member:
    #2976
    Messages:
    5
    Gender:
    Male
    Vehicle:
    1999 grand cherokee limited, 4.7
    none
    I have a 1999 grand Cherokee with the automatic zone control. Display in center of unit (all lit up when I ran diagnostic) left of screen is a/c button and dial for fan speed, auto manual select, right of display is recirc button and dial to select defrost, dash... When I push a/c button it doesn't come on, recirc works, button lights up, nothing on a/c button, no light, no cold air.
    The fuses are good, check relay in power dist. box under hood, coil pulls in, contacts read good. I jumped power to a/c clutch and it pulls in. I was already having trouble with azc, have to take motor behind glove box and let door fall for cold air and lock door in other position in winter for heat for drivers side. Replaced motor hoping that was it but it wasn't.
    I was hoping someone that knows more about it than me can verify bad azc before I replace.
    Thanks in advance.
     
To Top