1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Bad water temp sensor problems

Discussion in 'General Jeep Discussion' started by JeepXJ All the Way, Jan 18, 2017.

  1. Jan 18, 2017 at 7:53 PM
    #1
    JeepXJ All the Way

    JeepXJ All the Way [OP] New Member

    Joined:
    Jan 18, 2017
    Member:
    #833
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2000 lifted Jeep XJ
    6in lift
    Can a bad water temp sensor cause rough idling and my jeep stalling and shutting off while driving? I have been dealing with this problem for a while and I can't figure it out.
     
  2. Jan 19, 2017 at 6:26 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,237
    Gender:
    Male
    Welcome! Not sure if that would cause the issue. Do you have an engine light on?
     
  3. Jan 19, 2017 at 8:03 AM
    #3
    JeepXJ All the Way

    JeepXJ All the Way [OP] New Member

    Joined:
    Jan 18, 2017
    Member:
    #833
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2000 lifted Jeep XJ
    6in lift
    Yes I do, but I figured it probably was from the bad sensor
     
  4. Jan 19, 2017 at 11:23 AM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,237
    Gender:
    Male
    Get the codes read, and see what direction they point to.
     
  5. Jan 19, 2017 at 1:25 PM
    #5
    JeepXJ All the Way

    JeepXJ All the Way [OP] New Member

    Joined:
    Jan 18, 2017
    Member:
    #833
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2000 lifted Jeep XJ
    6in lift
    Alright will do thanks
     
  6. Jan 19, 2017 at 1:43 PM
    #6
    C2T

    C2T Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #42
    Messages:
    759
    Gender:
    Male
    First Name:
    Richard
    Helena, Montana
    Vehicle:
    Jeep
    2.5" AEV Dual Sport lift, 35" Treadwright Guard Dogs, Black Rock Wheels, AEV Front & Rear Bumpers with Tire Carrier, Fuel Caddy 10 gal. Aux. fuel tank, Warn 9.5ti, 125' synthetic winch line, front axle skid, 20" LED light bar , Bilstein Shocks, steel steering skidplate,
    Chris is correct...you need to get the codes. However, in answer to your question: YES, it can cause those kinds of issues. Still, get the codes first as they may lead you in another direction.
     
    chris4x4 likes this.
  7. Jan 19, 2017 at 6:00 PM
    #7
    JeepXJ All the Way

    JeepXJ All the Way [OP] New Member

    Joined:
    Jan 18, 2017
    Member:
    #833
    Messages:
    4
    Gender:
    Male
    Vehicle:
    2000 lifted Jeep XJ
    6in lift
    Alright thank you for the info!
     
To Top