1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Comanche no spark

Discussion in 'Other Jeep Vehicles' started by Grand Comanche, Jun 17, 2017.

  1. Jun 17, 2017 at 2:18 PM
    #1
    Grand Comanche

    Grand Comanche [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1576
    Messages:
    6
    Gender:
    Male
    Now i have searched this thread there was a few but i just cant fix it so my 87 comanche 2.5 2wd 4 speed has no spark at all but will crank over put a new crank sensor new ignition coil new starter relay and had ICM tested twice and it was good put new(kinda) battery terminals on it and still wont run help me please i miss my 4 cyl 4 speed. Thanks
     
  2. Jun 17, 2017 at 9:48 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Man.......I'm horrible with these older engines, but have you checked for a missing/blown fuse?
     
  3. Jun 18, 2017 at 6:38 AM
    #3
    Grand Comanche

    Grand Comanche [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1576
    Messages:
    6
    Gender:
    Male
    Yes i have checked under dash even just replaced them and pulled the 2 on the inside passenger side fender cleaned them tried swapping them but no luck
     
  4. Jun 18, 2017 at 10:12 AM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Next I would check all the ground connections
     
    OFFGRID likes this.
  5. Jun 19, 2017 at 2:52 PM
    #5
    Grand Comanche

    Grand Comanche [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1576
    Messages:
    6
    Gender:
    Male
    Ground to/from block to fire just found melted in half haven't tried to change it yet but it makes sense
     
  6. Jun 19, 2017 at 3:54 PM
    #6
    Grand Comanche

    Grand Comanche [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1576
    Messages:
    6
    Gender:
    Male
    Well ground strap on fire wall was the whole problem... makes me kinda sad lol. Thanks for mentioning all grounds never noticed that one a good hour half scope out found it I'm ashamed lol thanks for your replies
     
    chris4x4 likes this.
  7. Jun 19, 2017 at 7:48 PM
    #7
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Ashamed....seriously dude. Nothing to be ashamed about. What I have learned in my "real life" job. We see the same thing over and over every day. Some times we miss the basics. And I'm not saying that here, cause I never would have guessed the main ground. But some times it takes an outside eye to see something so common. We missed it.

    Nothing to be ashamed about. There are some of the most knowledgeable Jeep/motor/electrical/rebuild guys you will ever meet here. And if they don't know the answer. They will go out of their way to find the answer for you.

    Nothing to be ashamed about. Cool you found your issue. And Chris4x4 is one of those members. Ugly feet. Lol. But an awesome member/Admin here.
     
    OFFGRID likes this.
  8. Jun 21, 2017 at 8:32 AM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Glad to hear you got it! Thanks for updating us.
     
    JKBob 25 likes this.
  9. Jun 21, 2017 at 1:36 PM
    #9
    Grand Comanche

    Grand Comanche [OP] Member

    Joined:
    Jun 17, 2017
    Member:
    #1576
    Messages:
    6
    Gender:
    Male
    Well no longer ashamed of that ground no I'm ashamed that drive it 2 day an couldn't figure out why it was running really rough come to find out I didn't plug a spark plug wire on ha full of fun
    Thanks JKBob and welcome an thanks chris4x4
     
    chris4x4 and JKBob 25 like this.
  10. Jun 21, 2017 at 6:57 PM
    #10
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Once again dude. Some times we miss the basics because we over think it. Lol. Sorry dude. That's motors running bad 101. Check the plug wires first, and go from there. You should be ashamed. :facepalm:Just bustin on ya of coarse. Jeep jeep!
     
To Top