1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Corrosion

Discussion in 'Wrangler JK (2007-2017)' started by Billy1234, Apr 26, 2017.

  1. Apr 26, 2017 at 10:40 AM
    #1
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    924
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    Guy just saw this corrosion a couple days ago when I took the doors and top off... my rear window zipper is pretty corroded any ideas on how to get rid of it? It won't even zip anymore. I'd like to get it done before it rains like hell tomorrow haha. Any ideas would helpIMG_0904.jpg
     
  2. Apr 26, 2017 at 3:27 PM
    #2
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,913
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    IMO knock off some of the crud with an old tooth brush and try a little WD40 on the metal parts. The plastic zipper could use some lubricant or wax. If it turns out to be someones spilled milkshake or drink find'em an beat'em.
     
    JeepMafiaMama and JKBob 25 like this.
  3. Apr 26, 2017 at 4:32 PM
    #3
    OFFGRID

    OFFGRID Well-Known Member

    Joined:
    Oct 3, 2016
    Member:
    #317
    Messages:
    2,018
    Gender:
    Male
    First Name:
    Peter
    Houston
    Vehicle:
    1979 Jeep CJ7, 258, TH350, NP208
    Howell fuel injection, header, HEI distributor, TH350, NP208, SOA lift with YJ springs in the front & GW springs in the Rear. AMC20 with G2 1 piece chromos trussed, Dana 30 with G2 chromos and 760x ujoints and MM Stainless Hubs, Geared 4.56. Tom Woods shafts, Metal cloaks, Caged, 37" Toyo MTs.
    That looks like salt corrosion. Maybe try spraying it with "Saltaway".
     

Products Discussed in

To Top