1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Hey y'all just an update with this cherokee and a random question with it

Discussion in 'Cherokee' started by Billy1234, Mar 13, 2020.

  1. Mar 13, 2020 at 10:23 AM
    #1
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    923
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    So I havent been working on it took a brake to clear my head with it and other things going on. But back at it again and had a few questions. I have power going to obd2 port but none going to the fuse at all and fuse is not blown. Does that mean the fuse box is bad?
     
  2. Mar 13, 2020 at 4:21 PM
    #2
    BigNuge

    BigNuge Well-Known Member

    Joined:
    Jul 27, 2019
    Member:
    #3595
    Messages:
    124
    Gender:
    Male
    First Name:
    Jim
    Granite State
    Vehicle:
    99 XJ
    I don’t blame you for taking a break, sometimes you have to step away and come back to it later.

    This OBDII issue you’re having is pretty damn weird...
     
    Bob likes this.
  3. Mar 15, 2020 at 8:29 PM
    #3
    Jim Beam

    Jim Beam Well-Known Member

    Joined:
    Feb 11, 2019
    Member:
    #2891
    Messages:
    348
    Gender:
    Male
    First Name:
    Donald
    Vehicle:
    1986 CJ7
    Fuel Injection, Dana 44s, T18, 4.10s w/lockers
    I have seen fuses go bad and visually they look just fine.
     
To Top