1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

I'm Guessing Map Sensor

Discussion in 'General Jeep Discussion' started by Jim Beam, Nov 25, 2019.

  1. Nov 25, 2019 at 3:49 PM
    #1
    Jim Beam

    Jim Beam [OP] Well-Known Member

    Joined:
    Feb 11, 2019
    Member:
    #2891
    Messages:
    254
    Gender:
    Male
    First Name:
    Donald
    Vehicle:
    1986 CJ7
    Fuel Injection, Dana 44s, T18, 4.10s w/lockers
    I took my CJ for a steep climb in a long canyon of about 3000 feet up and got a check engine light, this indicated a rich condition. Oddly enough a Cherokee with a 4.0 behind me got the same results. An engine restart solved the problem until another 1000 ft. or so it went off again solved with another restart. I continued up another 2000 ft. and back down to start altitude without any further issues. I have done this trail many times before without any lights going off. My CJ has the 4.2 with a t.b.i and GM computer. So I am thinking the map sensor or the computer can't keep up with the steep climb. Can anyone figure this one out?
     

Products Discussed in

To Top