1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Jeep Cherokee 4cyl 2.5L idles rough and stalls out

Discussion in 'Cherokee' started by joeyourbro, Oct 11, 2016.

  1. Oct 11, 2016 at 5:24 PM
    #1
    joeyourbro

    joeyourbro [OP] New Member

    Joined:
    Oct 11, 2016
    Member:
    #349
    Messages:
    1
    Gender:
    Male
    First Name:
    Joe
    Vehicle:
    Jeep Cherokee 4cyl 2.5L
    nada
    Alright so me and my dad got a rust free, 2 door XJ with 112k on it for $800. Ran good for quite a bit until it started having some problems with idling. Sounds like it idles high and then bogs way down till its about to stall, and if it doesn't stall, it idles way high again. Throttle response seems kinda delayed too.

    I cleaned out the throttle body and IAC bullshit today, no help. Previously my dad messed with the fuel pressure and a friend recommended that I take out the cat to see if it was clogged, didn't work. Really just looking for some pointers in which direction I should head next. I have links to some vids of the jeep running:

    https://youtu.be/CIWg_KQN6ek
    https://youtu.be/0W3giotvHYE
     
  2. Jan 3, 2017 at 9:43 AM
    #2
    Nikkifm22

    Nikkifm22 New Member

    Joined:
    Jan 3, 2017
    Member:
    #734
    Messages:
    2
    Gender:
    Female
    First Name:
    Nikki
    Vehicle:
    2007 Jeep Grand Cherokee Limited
    I have an 07 Jeep Grand Cherokee limited, and I am having the same issues with it idling rough. My RPMs jump and it feels like it's going to stall out, it never has yet but t makes me nervous. Have u had any help on this issue? Any advice or input u could give me?
    Thanks!
    Nikki
     
  3. Jan 3, 2017 at 8:33 PM
    #3
    C2T

    C2T Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #42
    Messages:
    763
    Gender:
    Male
    First Name:
    Richard
    Helena, Montana
    Vehicle:
    Jeep
    2.5" AEV Dual Sport lift, 35" Treadwright Guard Dogs, Black Rock Wheels, AEV Front & Rear Bumpers with Tire Carrier, Fuel Caddy 10 gal. Aux. fuel tank, Warn 9.5ti, 125' synthetic winch line, front axle skid, 20" LED light bar , Bilstein Shocks, steel steering skidplate,
    Hi Joe; (and Nikki too)

    Check for any loose or leaking vacuum hoses or loose components. (thinking about intake components here) There are lots of possible causes of a rough idle. For instance: A fouled injector is also a possibility. You might want to check on the coolant temp sensor (on the intake manifold). If it is acting up the engine may think it is cold, causing it to run rich. Best to start with the easy (and cheaper) things first.

    Good luck!! :)
     
  4. Jan 9, 2019 at 11:38 AM
    #4
    Prerunner1982

    Prerunner1982 Well-Known Member

    Joined:
    Aug 4, 2017
    Member:
    #1745
    Messages:
    957
    Gender:
    Male
    First Name:
    Jon
    Vehicle:
    93 XJ 2 door, 97 XJ 4 door, 00 XJ 4 door
    @Nikkifm22 Have you cleaned your IAC (Idle Air Control) valve? When was the last time the spark plugs were changed?
     
  5. Jan 9, 2019 at 12:35 PM
    #5
    Awrench

    Awrench Well-Known Member

    Joined:
    May 12, 2018
    Member:
    #2303
    Messages:
    700
    Gender:
    Male
    Vehicle:
    3 jeeps
    PRERUNNER - these are OLD and dead - why did we dig them up?:deadhorse:
     
  6. Jan 9, 2019 at 12:56 PM
    #6
    Prerunner1982

    Prerunner1982 Well-Known Member

    Joined:
    Aug 4, 2017
    Member:
    #1745
    Messages:
    957
    Gender:
    Male
    First Name:
    Jon
    Vehicle:
    93 XJ 2 door, 97 XJ 4 door, 00 XJ 4 door
    I'm a necromancer. Actually I didn't notice the date. I saw another post by Nikki and she only had 2 posts so I assumed the other post was recent as well. Maybe she is still having the same problem? There wasn't a conclusion.
     
  7. Jan 9, 2019 at 3:32 PM
    #7
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,968
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Perhaps there was a happy ending for that problem as she has moved onto wheels falling off. Hope we will get a conclusion on the loose or missing lug nuts.
     
To Top