1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Jeep not starting

Discussion in 'Cherokee' started by Jeff fxwthy, Sep 26, 2016.

  1. Sep 26, 2016 at 5:42 PM
    #1
    Jeff fxwthy

    Jeff fxwthy [OP] New Member

    Joined:
    Sep 26, 2016
    Member:
    #279
    Messages:
    1
    Gender:
    Male
    First Name:
    Jeff
    Vehicle:
    99 jeep grand cherokee 4.0 4X4
    My jeep will not start at all. It ran fine around this time last year but slowly it started acting up almost like it was running out of gas. Then a few months ago I took it from ky to Iowa and stayed for about a week then the day I got back to ky it stalled out and died. And it sounded like it was running out of gas but it didnt. And so I put all new spark plugs in it but that didn't work and I took off my fuel line to see if it was getting fuel (it was) and it still didn't run so after it sat there a couple days I went to start it back up again but I messed with the cps on top of the distributor and it started. Then a couple days later it stopped running all together and I've since changed out the fuel pump cleaned the injectors changed the cps distributor and rotor and even cleaned out the map sensor. But I had the computer scanned and only found one code that popped up was p1491 and all my other readings were normal. I have no clue what is wrong with my jeep. Please help me.
     
  2. Sep 26, 2016 at 6:02 PM
    #2
    Bob

    Bob Well-Known Member Moderator

    Joined:
    Jul 18, 2016
    Member:
    #1
    Messages:
    461
    Gender:
    Male
    Battery and alternator ok?
     
  3. Sep 26, 2016 at 8:16 PM
    #3
    C2T

    C2T Well-Known Member

    Joined:
    Jul 31, 2016
    Member:
    #42
    Messages:
    759
    Gender:
    Male
    First Name:
    Richard
    Helena, Montana
    Vehicle:
    Jeep
    2.5" AEV Dual Sport lift, 35" Treadwright Guard Dogs, Black Rock Wheels, AEV Front & Rear Bumpers with Tire Carrier, Fuel Caddy 10 gal. Aux. fuel tank, Warn 9.5ti, 125' synthetic winch line, front axle skid, 20" LED light bar , Bilstein Shocks, steel steering skidplate,
    You need to start eliminating some things. I know you stated you replaced the plugs but you do not indicate whether you checked to see if you are getting spark. You state you checked to see if fuel is flowing but did not indicate that you tested the fuel pressure. Are you getting a fuel smell when you crank it (flooding?) Is it cranking normally?

    Welcome to the site!!
     

Products Discussed in

To Top