1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Jeep won't start and check engine light now on

Discussion in 'Wrangler YJ (1986-1995)' started by Jeepjoc, Sep 25, 2017.

  1. Sep 25, 2017 at 8:55 PM
    #1
    Jeepjoc

    Jeepjoc [OP] Active Member

    Joined:
    Jun 3, 2017
    Member:
    #1520
    Messages:
    34
    Gender:
    Male
    First Name:
    Dennis
    Albertville, AL
    Vehicle:
    1995 YJ Wrangler Rio Grande
    Today I took my jeep to the gas station to fill it up. After filling it up I jumped in and turned the key and got nothing. My wife was with me and I had her behind the wheel and pushed her to get it started. Drove home and the jeep ran beautifully except the "Check Engine" light did come on. Parked in the drive way and decided to try again, nothing. Anybody got any ideas about where to start looking. My thoughts at this point is ignition.

    Cheers - Jeepjoc
     
  2. Sep 26, 2017 at 6:55 AM
    #2
    OFFGRID

    OFFGRID Well-Known Member

    Joined:
    Oct 3, 2016
    Member:
    #317
    Messages:
    1,272
    Gender:
    Male
    First Name:
    Peter
    Houston
    Vehicle:
    1979 Jeep CJ7, 258, TH350, NP208
    Howell fuel injection, header, HEI distributor, TH350, NP208, SOA lift with YJ springs in the front & GW springs in the Rear. AMC20 with G2 1 piece chromos trussed, Dana 30 with G2 chromos and 760x ujoints and MM Stainless Hubs, Geared 4.56. Tom Woods shafts, Metal cloaks, Caged, 37" Toyo MTs.
    Starter Relay, Starter, ignition, weak battery. Check the easy stuff first. See if you can jump it. Check battery cables for good solid connection.
     
    JKBob 25 likes this.
  3. Sep 26, 2017 at 8:24 AM
    #3
    aggrex

    aggrex Jeepin

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    710
    DE
    Vehicle:
    Backcountry
    RockHard>CMM>TF>SpringTail>67design>QT>RR>Bolt>GPCA>Curt>MagnaFlow
    Since the engine light appeared I would try to get the code to help with the diagnosis of the underlying proble in addition to what OffGrid offered as steps.
     
    JKBob 25 likes this.
  4. Sep 26, 2017 at 6:53 PM
    #4
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    1,490
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 305/65R/17. Numerous other mods. And more to come
    Agreed. I'm sure you know, your in good hands. I may not be able to help....But I'm sure other members might be able to.

    Subbed to see the outcome. Good luck Jeepjoc.
     
  5. Sep 27, 2017 at 2:03 PM
    #5
    dballhead

    dballhead New Member

    Joined:
    Sep 26, 2017
    Member:
    #1911
    Messages:
    4
    Gender:
    Male
    Vehicle:
    97wrangler
    None yet
    Before you go all crazy jump start the jeep while it is running remove one side off the battery terminal if jeep cuts off your alternator is bad if it stay running replace terminal then do other tests ,good luck!!
     
    JKBob 25 likes this.
  6. Oct 5, 2017 at 1:58 PM
    #6
    Jeepjoc

    Jeepjoc [OP] Active Member

    Joined:
    Jun 3, 2017
    Member:
    #1520
    Messages:
    34
    Gender:
    Male
    First Name:
    Dennis
    Albertville, AL
    Vehicle:
    1995 YJ Wrangler Rio Grande
    Update. After doing all the checks that I could think of, it turned out to be a bad battery. Checked the battery date and it was a little over six year old battery, so I guess it didn't owe me anything.

    Cheers & Beers - Jeepjoc
     
    JKBob 25 and chris4x4 like this.
  7. Oct 5, 2017 at 2:02 PM
    #7
    aggrex

    aggrex Jeepin

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    710
    DE
    Vehicle:
    Backcountry
    RockHard>CMM>TF>SpringTail>67design>QT>RR>Bolt>GPCA>Curt>MagnaFlow
    Thanks for the update. The lowly but highly valuable battery lasted 6 years and decided to fail before the winter season.
     
    JKBob 25 likes this.
  8. Oct 5, 2017 at 2:47 PM
    #8
    Jeepjoc

    Jeepjoc [OP] Active Member

    Joined:
    Jun 3, 2017
    Member:
    #1520
    Messages:
    34
    Gender:
    Male
    First Name:
    Dennis
    Albertville, AL
    Vehicle:
    1995 YJ Wrangler Rio Grande
    Yep, Now gotta start thinkin' about puttin' all the side curtains back on!!!

    Cheers & Beers - Jeepjoc
     
    JKBob 25 likes this.
  9. Oct 5, 2017 at 4:16 PM
    #9
    Offroad798

    Offroad798 Active Member

    Joined:
    Oct 2, 2017
    Member:
    #1927
    Messages:
    38
    Gender:
    Male
    First Name:
    Bob
    Florida
    Vehicle:
    2015 Rubicon
    fenders, bumpers, winch, inner fenders, cb, headliner storage, oil pan armor
    Hey just seen your post. Just throwing my two cents out again. We are talking basics here. Barring accidents, water damage, wrecks and human error etc. The CEL light usually turns on when it detects a sensor that goes out of tolerance that directly affects emissions. They will call the sensors around your engine and exhaust. If the voltage to the computer drops too low you will have all kind of weird things happen. Voltage goes to high you can fry the computer hence trickle charge. Since the electrical system is not part of emissions it will not call out the starter, alt DIS, etc. This comes down to the tech using meters and a scanner to help T-shoot a problem. Careful on pulling battery cables of while vehicle is running, work great on older vesicles ( non computer vehicles). Ever had the problem while driving everything works good. Then stopped at a red light the car ran really bad and died. Well the alt is running the car while driving and at idle the battery handles this job. They do compliment each other. Same reason why you idle up when winching. Just keeping it simple here. Did you ever find out what the code was? Glad you got it fixed.
     
    JKBob 25 likes this.
  10. Oct 5, 2017 at 6:04 PM
    #10
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    1,490
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 305/65R/17. Numerous other mods. And more to come
    Cool you found the issue. Thanks for the update. I could bust your balls on it. But I'll leave ya alone this time. Lollll. :cheers:
     
To Top