1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

No power after jumping

Discussion in 'General Jeep Discussion' started by Guitarland86, Jul 18, 2017.

  1. Jul 18, 2017 at 8:15 AM
    #1
    Guitarland86

    Guitarland86 [OP] New Member

    Joined:
    Jul 18, 2017
    Member:
    #1688
    Messages:
    2
    i had left the keys in the ignition last night and had an almost completely dead battery this morning. i got a jump from a neighbor and power came back for a moment. i turned the key to start the vehicle, it clicked once, and then all power dropped - lights, dash, everything. I'm at a loss. im guessing a battery fuse, but have no clue where to find it. I checked the manual, but didn't see a ''battery fuse" Anybody have a clue as to what happen or what to look at to fix this?
    i had left the sunroof open and it did rain a bit last night. i'm not sure if that could have done some electrical short but i thought it may be pertinent.
     
  2. Jul 18, 2017 at 8:28 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Battery might be dead beyond being able to be RE charged. If jumped to another vehicle, is everything operational? And welcome to the site!!
     
    JKBob 25 and OFFGRID like this.
  3. Jul 18, 2017 at 8:39 AM
    #3
    Guitarland86

    Guitarland86 [OP] New Member

    Joined:
    Jul 18, 2017
    Member:
    #1688
    Messages:
    2
    Thanks for having me! unfortunately, no power whatsoever while it is jumped to another vehicle. power only came back when i first hooked them up and then power dropped after turning the key once.
     
  4. Jul 18, 2017 at 9:18 AM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    I would try swapping with a good battery, and see if the issue is the battery. Easiest thing first. If that's not it, I would check all connected tons, mKing sure connection surfaces are clean with good contact. Then, search for a clown fuse.
     
  5. Jul 18, 2017 at 3:43 PM
    #5
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,966
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    If I suspect a severely discharged battery or battery with dead cells, try a jump without a direct connection to your battery.
     
    JKBob 25 and chris4x4 like this.
To Top