1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

O2 code

Discussion in 'Wrangler JK (2007-2017)' started by Billy1234, Jul 25, 2017.

  1. Jul 25, 2017 at 7:24 AM
    #1
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    924
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    Is this a bad thing or just need the sensor switched?IMG_1284.jpg
     
  2. Jul 25, 2017 at 8:40 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,048
    Gender:
    Male
    Check for a bad connection, or broken wires first.
     
    JKBob 25 likes this.
  3. Jul 25, 2017 at 11:01 AM
    #3
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    924
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    Ok thank you chris just needed to know where to start
     
    JKBob 25 likes this.
  4. Jul 25, 2017 at 7:18 PM
    #4
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Billy....check for mud build up too. Lolll.,:goingcrazy:
     
  5. Jul 26, 2017 at 2:35 AM
    #5
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    924
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    Lol i did bob not to much is built up under it i got alot of it off when i was able to wash her lol that was my first thought actually lol.
     
    JKBob 25 likes this.
  6. Jul 26, 2017 at 6:30 PM
    #6
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,748
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    You figure this problem out dude? Need to keep on jeepin. :jeep:
     
  7. Jul 26, 2017 at 8:57 PM
    #7
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,941
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    P0152 refers to the oxygen sensor circuit bank 2, sensor 1 before the converter towards the front. After checking the o2 sensor circuit wiring then suspect the o2 sensor. There are other potential causes of the code but thats where I would start.
     
  8. Jul 27, 2017 at 4:28 AM
    #8
    Billy1234

    Billy1234 [OP] Well-Known Member

    Joined:
    Mar 11, 2017
    Member:
    #1131
    Messages:
    924
    Gender:
    Male
    First Name:
    William
    Vehicle:
    1997 XJ 2 door
    None yet
    Gotta check those today @JKBob 25 been doing spark plugs and fighting with Amazon @chris4x4 they sent me the completely wrong harness im not doing a touch screen yet i dont need the harness for one witch is what they sent... gotta love it first time they ever sent me the wrong thing
     
    JKBob 25 and chris4x4 like this.

Products Discussed in

To Top