1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Saying Hi

Discussion in 'New Member Introductions' started by Jrgabriel, Jul 14, 2019.

  1. Nov 17, 2019 at 7:38 AM
    #81
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Update - that dealership was working on car for free and GM trying to make things right. This is still an issue and I’m at 5 months. The only reason I’ve been playing this game is because my options were limited and they did the work for free (the following times) and provided me with a loaner.
    After a little research...I’m thinking Tone Ring/Reluctor might be the culprit. My other thoughts are that it is the Alternator/Battery (Not certain if this could cause my problem)??
    What would keep causing that sensor to go bad and then to replace...me drive it 200-400 miles and problem all over again? How much would it cost toreplace? Thoughts on next steps?
     
  2. Nov 17, 2019 at 9:39 AM
    #82
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,463
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Commend you on your perseverance + patience but I'm sticking with my final answer on this JGC. Clear the code and move onto the next.
     
  3. Nov 17, 2019 at 12:36 PM
    #83
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Move on to the next what? So the service history shows that an alternator was replaced on the vehicle about a month before I bought it...my question is - can one of these being slightly bad/faulty cause a P0339 code and the car to run rough?
     
  4. Nov 17, 2019 at 12:52 PM
    #84
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Besides what I wrote above...this was the last service on the car right before I purchased it. Seemed to have no problems before this and then the P0339 and running rough and engine light coming on.

    0B54EFAB-674B-495C-AD96-8F3318E41F73.jpg
     
  5. Nov 17, 2019 at 4:13 PM
    #85
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I may be slightly wrong on what they put on paperwork. I know They said p0339 but paperwork shows p0340 code. So history is that before I purchased they replaced pcm and alternator. I posted all paperwork here-
    https://www.jeeps.net/threads/po340-code-from-a-different-angle.4267/
     
  6. Nov 17, 2019 at 4:16 PM
    #86
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Sin
    since you and aggrex were helping. I need a little more advice to cross finish line. Paperwork is here - https://www.jeeps.net/threads/po340-code-from-a-different-angle.4267/
    And above this post to aggrex I explain a little history on the alternator and pcm replacement before I purchased.
     
  7. Nov 18, 2019 at 10:23 AM
    #87
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    So I get car back up to dealership (last 2 days engine light is on) and they hook up scan test and say the code is cleared. What!!?? No engine light on now and they say they cannot pull up the code that was on for two days...?!!
     
  8. Nov 18, 2019 at 1:13 PM
    #88
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    Brought it in to dealership today with engine light on. They go to read it and apparently code cleared out. I drive home and it is still running rough in that 55-70 speeds. Wife takes it to work and engine light goes back on and seatbelt light is blinking with seatbelt plugged in. Thoughts?
     
  9. Nov 18, 2019 at 5:52 PM
    #89
    boondoc89

    boondoc89 Well-Known Member

    Joined:
    Feb 3, 2017
    Member:
    #912
    Messages:
    760
    Gender:
    Male
    First Name:
    alex
    Vehicle:
    08 JKU
    3 inch zone lift. Fox 2.0 shocks. 35 inch nitto ridge grapplers. Bushwacker flat fenders. No name steel bumpers front and back for now.
    Maybe the entire PCM/ECM needs updated?? You also might have a short circuit somewhere along the lines that is causing all this gremlins to arise. Are you in the northern part of the states in the salt belt?? I'm dealing with gremlins of my own with my headlights and it's due to several shorts in the wiring. And from what I've been told it's because of the salt over the years eating away at all my wiring.... I feel your frustration my man!! :annoyed::annoyed::annoyed:
     
    Jrgabriel [OP] likes this.
  10. Nov 18, 2019 at 6:19 PM
    #90
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I am in the South East (Northwest Alabama...about 10 miles away from Tennessee).
    So the PCM was replaced twice already. I’m thinking that something is all related with the first fix for Flashing Battery light and Air bag light on - fix was to change PCM and Alternator.
    I’m curious if they did the programming correctly or I have encountered two bad PCMs...or this is something other than that but would cause all these problems.
     
  11. Nov 18, 2019 at 9:21 PM
    #91
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I
    arghhhhhh I need HELP!!! I have seriously been sucked down the internet rabbit hole these last few days!!!
     
  12. Dec 30, 2019 at 7:27 PM
    #92
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I’m
    Recall just came out with no remedy available yet. Apparently dealer replaced the old relay. I’m picking up car tomorrow. Not certain if this would be causing the crankshaft and camshaft codes...? They say they have driven it 280 miles with absolutely no problems. We will see....it’s been 6 freaking months!!
     
  13. Dec 30, 2019 at 7:28 PM
    #93
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    E7BCC1DA-1615-499B-B20F-9192CAD1070B.jpg
     
    JKBob 25 likes this.
  14. Dec 30, 2019 at 7:43 PM
    #94
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    3,463
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    That's sort of good news that a "fix" may be on the way. But 280 miles, really? @55mph that's 5 hr road trip
     
    boondoc89 and JKBob 25 like this.
  15. Dec 30, 2019 at 7:44 PM
    #95
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,694
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Well....lets hope this is the issue dude.:thumbsup:
    After all the BS you've been thou. You deserve a a break. And your Jeep back.....And running. :)
     
  16. Dec 30, 2019 at 7:46 PM
    #96
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I guess my thought is - could that have been the culprit this whole time!!?? Weird that it would throw P0339 and P0334 codes
     
  17. Dec 30, 2019 at 7:48 PM
    #97
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    They asked if one of their employees could drive it home one night and also were driving it around to pick up parts. I have had a brand new loaner (or a couple anyways) for 6 months!! Craziness
     
  18. Dec 30, 2019 at 7:49 PM
    #98
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,694
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Or like 6 months of...it's your turn to pick up lunch......o_O
     
  19. Dec 30, 2019 at 7:50 PM
    #99
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I think the 280 miles was in the last 2 weeks. For the most part it was just sitting up there...
     
  20. Dec 30, 2019 at 7:52 PM
    #100
    Jrgabriel

    Jrgabriel [OP] Well-Known Member

    Joined:
    Jul 14, 2019
    Member:
    #3519
    Messages:
    172
    Gender:
    Male
    Vehicle:
    2011 Jeep Grand Cherokee 2wd 5.7 Hemi
    I’m hopeful!!! Please let it be good tomorrow...I’m loosing my mind over this crap!! In all my life I have never had a problem like this!!
     
    JKBob 25 likes this.
To Top