1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Uconnect rbz not working

Discussion in 'Compass' started by clueless, Nov 17, 2021.

  1. Nov 17, 2021 at 1:48 PM

    clueless [OP] New Member

    Nov 17, 2021
    2014 Jeep Compass latitude
    Hi all. I have a 2014 Jeep Compass latitude with about 133,000 miles on it. My touch scree started to be non-responsive a few weeks ago, which was very frustrating, so I decided to buy a new digitizer for the screen and replace it myself. I did everything step by step, and the screen now works, BUT my hard buttons (volume, phone, VR, media, etc) do not work.

    I've taken this thing apart like 7 times to make sure all my connections are good, but I'm not quite sure what to do now. My phone will connect to bluetooth, and on a phone call I can use the screen, but once the call is ended, it goes back to the blank screen with the time.

    I've tried everything I can think of. I disconnected my battery for about an hour and a half, nothing. I haven't tried the fuse yet, but I don't think that would be it? not sure if anyone has recommendations, before I make the trip to the dealer(on a very very tight budget). TIA

Products Discussed in

To Top