1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Uconnect screen frozen

Discussion in 'Audio & Video' started by American02, Nov 21, 2017.

  1. Nov 21, 2017 at 4:55 AM
    #1
    American02

    American02 [OP] New Member

    Joined:
    Nov 21, 2017
    Member:
    #1998
    Messages:
    1
    Gender:
    Male
    none
    My jeep LCD uconnect touch screen is frozen...I can only access some of the application using the speech function, even then I cant access my climate and climate control due to the fact that touch screen is not responding.....

    I tried doing a factory reset and when I get to the final step which prompts you to enter YES or NO I cant execute it..

    Is their another way to fix this issue or is my radio system is not good?......By the way the radio works, Nav works only on voice comment, not by using the touch screen commend

    I was thinking of disconnecting the battery for few minutes to see if the radio system resets,,,

    please provide any feedback..

    Thanks
     
  2. Nov 21, 2017 at 5:09 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,710
    Gender:
    Male
    Welcome to the site! Is or still under warranty by chance?
     
  3. Nov 21, 2017 at 5:16 AM
    #3
    ziggy

    ziggy Active Member

    Joined:
    Oct 3, 2017
    Member:
    #1929
    Messages:
    28
    Gender:
    Male
    First Name:
    steve
    angleton tx
    Vehicle:
    2010 jeep wrangler sport
    warn winch- p255/75/r17 bf Goodrich mamba wheels quadratec sliders and rear bumper and spare tire carrier
    Goodmorning 02. Welcome. Did you check out the owners manual? Sometimes they are a little help. Don't know about the battery cable, could work. Try and let us know. Again, welcome.
     
  4. Nov 21, 2017 at 9:30 AM
    #4
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,453
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Welcome American02! Try the battery disconnect. It might work like booting your pc otherwise it doesn't hurt to try.
     
  5. Nov 21, 2017 at 11:13 AM
    #5
    Prerunner1982

    Prerunner1982 Well-Known Member

    Joined:
    Aug 4, 2017
    Member:
    #1745
    Messages:
    876
    Gender:
    Male
    First Name:
    Jon
    Vehicle:
    93 XJ 2 door, 97 XJ 4 door, 00 XJ 4 door
    Take the cartridge out, blow in it, reinsert cartridge...... It worked on Nintendos.. :notsure:

    As suggested try disconnecting the battery, you might even touch the positive and negative battery cables together. I have personally seen 2 JKs that would not start, jump start, pull/push start, swap batteries...NOTHING... touch the cables together to clear the computer and they start right up.
    It is worth a shot for this too..
    Now the engine may not run quite as well as the computer will have to relearn some parameters.
     
    Last edited: Nov 21, 2017
  6. Nov 21, 2017 at 11:29 AM
    #6
    ziggy

    ziggy Active Member

    Joined:
    Oct 3, 2017
    Member:
    #1929
    Messages:
    28
    Gender:
    Male
    First Name:
    steve
    angleton tx
    Vehicle:
    2010 jeep wrangler sport
    warn winch- p255/75/r17 bf Goodrich mamba wheels quadratec sliders and rear bumper and spare tire carrier
    o2, called the Mopar dealership & talked to the service manager. Sounds like they are having a s#$t load of problems with uconnect. He said you could try a reset- unhook both battery cables, take out battery fuse, wait 5 min. and reattach cables & reinstall fuse.
    Good luck--- maybe next, sacrifice a goat by the full moon???
    Steve
     
    chris4x4 likes this.
  7. Nov 21, 2017 at 6:52 PM
    #7
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,202
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Welcome to the forum Americian02.

    Some great advice already given. I'm all for disconnecting battery. But based on what @ziggy researched. It may not work. So I'd have to go with the sacrificing the goat thing. But then again......@Prerunner1982 may be on to some thing. o_O
     
  8. Jun 19, 2018 at 9:00 AM
    #8
    Azalexi

    Azalexi New Member

    Joined:
    Jun 19, 2018
    Member:
    #2378
    Messages:
    3
    Gender:
    Female
    @JKBob 25, did you ever figure out how to resolve your uconnect issue? Mine is doing the same. Frozen on my screen. Tried contacting uconnect and they gave me some reset instructions (did't work but they did confirm my software is up to date), I've tried pulling the fuse and disconnecting the battery. Nothing. I'm trying all options before I take it into the dealer! It's out of warranty (2010) and NOT fun to drive to the beach with no radio!
     
  9. Jun 20, 2018 at 7:11 PM
    #9
    JKBob 25

    JKBob 25 Well-Known Member

    Joined:
    Mar 22, 2017
    Member:
    #1197
    Messages:
    3,202
    Gender:
    Male
    First Name:
    Bob
    Jersey Shore, NJ
    Vehicle:
    2016 JK Wrangler Sport
    2" Superlift kit. 315/ 70/17.
    Hey @Azalexi. Sorry....wasn't me with the issue. I believe it was American02. Hi is post was back in Nov of last year. His only post. He probably won't be back. :notsure:. Sorry.....I can't help ya with this. Hope you figure out your issue. Right there with ya. Need my tunes...
     
    chris4x4 likes this.
  10. Jun 21, 2018 at 5:38 AM
    #10
    Azalexi

    Azalexi New Member

    Joined:
    Jun 19, 2018
    Member:
    #2378
    Messages:
    3
    Gender:
    Female
    Hi JKBob, thanks for the reply! Bummer ... I'm trying to avoid going to the dealership, lol! I've posted on a couple other forums so maybe someone else has an idea!
     
    JKBob 25 likes this.
  11. Jan 25, 2019 at 1:06 PM
    #11
    Lissaloo

    Lissaloo New Member

    Joined:
    Jan 25, 2019
    Member:
    #2853
    Messages:
    1
    Vehicle:
    Jeep Grand Cherokee
    Press in and hold your volume and tuner button at the same time for about 10 seconds until the screen shuts down. Fixed my frozen Bluetooth. Just a soft reset. I know this is old but comes up on google searches and hopefully it will help someone else.
     
  12. Jan 25, 2019 at 2:13 PM
    #12
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,453
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Welcome @Lissaloo . Always good to share tips that have worked for you as today's vehicles have a ton of integrated electronics for every simple task making repairs difficult.
     
  13. Jun 9, 2019 at 9:42 AM
    #13
    Ginnjuice

    Ginnjuice New Member

    Joined:
    Jun 9, 2019
    Member:
    #3340
    Messages:
    1
    Vehicle:
    Jeep Grand Cherokee Diesel
    Thanks, Lissaloo! On a 10 hour road trip and console froze. Soft reset holding volume and tunner until screen went blank and reloaded worked! Thank God! Easy peasy. Thanks again!
     
  14. Jun 9, 2019 at 10:24 AM
    #14
    aggrex

    aggrex Well-Known Member

    Joined:
    Sep 12, 2016
    Member:
    #203
    Messages:
    2,453
    DE
    Vehicle:
    Backcountry '16
    Tuffy>AEV>TTO>JW>STech>EVOcage>MagnaFlow>SpiderTrax>RockHard>TF>SpringTail>67design>Bolt>GPCA>Curt>
    Welcome @Ginnjuice...glad to hear the "fix" worked for you too! Post an intro and some pics as you learn and share on jeeps.net too
     

Products Discussed in

To Top