1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

V8 Grand Cherokee seems to be running on 4 cylinders

Discussion in 'Grand Cherokee' started by Hannah_g22, Jun 5, 2017.

  1. Jun 5, 2017 at 9:43 AM
    #1
    Hannah_g22

    Hannah_g22 [OP] New Member

    Joined:
    Jun 5, 2017
    Member:
    #1530
    Messages:
    2
    Gender:
    Male
    First Name:
    Glen
    Vehicle:
    2001 jeep grand cherokee laredo
    Hi everyone I'm the new guy and I'm having some issues with my WJ. I recently rebuilt the motor which was a 4.7 poertech v8. It ran beautifully for a week and a half. Now my issue is that it's running at a rough idle with a god awful gas exhaust smell. Plus when you unhook the harness from all the coil packs and injectors on the driver side it does nothing. So it seems to be running on 4 cylinders on the passenger side. I've changed all the coil packs, all injectors, and the crank shaft sensor and showed no change. I need help please!!!
     
  2. Jun 5, 2017 at 12:40 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Welcome. Could be a bad wire harness.?
     
    Bob likes this.
  3. Jun 5, 2017 at 12:55 PM
    #3
    Hannah_g22

    Hannah_g22 [OP] New Member

    Joined:
    Jun 5, 2017
    Member:
    #1530
    Messages:
    2
    Gender:
    Male
    First Name:
    Glen
    Vehicle:
    2001 jeep grand cherokee laredo
    It ran great for a good week and a half. I babied the motor with it being new and rebuilt. Then all the sudden it just started hesitating and running weird on the way to work. I was wondering if it could be a pcm issue.
     
  4. Jun 6, 2017 at 2:06 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    4,042
    Gender:
    Male
    Are there any engine codes being thrown?
     
    JKBob 25 likes this.
To Top