1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

What's wrong with my JGC?

Discussion in 'Cherokee' started by danaraeeee, Dec 16, 2016.

  1. Dec 16, 2016 at 8:44 AM
    #1
    danaraeeee

    danaraeeee [OP] New Member

    Joined:
    Dec 16, 2016
    Member:
    #657
    Messages:
    1
    Gender:
    Female
    First Name:
    Dana
    Vehicle:
    2008 Grand Cherokee Overland
    I just bought my 2008 JGC Overland a month and a half ago. I realized the stereo units in them are pieces of crap and I will have to get an after market stereo. But then...
    I have had occasional issues with the remote start- Jeep won't start and just makes a terrible buzzing noise.
    My heat isn't working right now. It was working when I bought it, then it cut out, then it started working but it took forever to heat up and work, now it's not working anymore. Also, when I turn the heat on, it makes a terrible buzzing noise from the dash...
    My check engine light has come on and then gone off and come back on. Occasionally, the jeep sounds pretty loud when driving. Also, the check gauges light is intermittently coming on and off. What gauges?
    I hope I didn't buy a piece...
     
  2. Dec 16, 2016 at 9:55 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine Moderator

    Joined:
    Jul 19, 2016
    Member:
    #2
    Messages:
    3,040
    Gender:
    Male
    Welcome! That's quite the issue. Hopefully someone can chime in lending Assistance.
     
  3. Dec 16, 2016 at 1:20 PM
    #3
    jeepinghillbilly

    jeepinghillbilly Well-Known Member

    Joined:
    Dec 16, 2016
    Member:
    #656
    Messages:
    89
    Gender:
    Male
    First Name:
    Hillbilly
    WV
    Vehicle:
    99 TJ / 79 CJ5
    99 TJ locked/locked, 4" lift, 1" body lift, skids and more skids, geared 4.88s, super shorty sye, all Rockmen adjustable arms, D44 rear, D30 front, all disc brakes, AX15 manual 5 speed, waren winch, currie tie rod, a drop down tail gate and heater relays upgrade to keep my heater switch from melting lol, and lots more stuff. 79 CJ5 with 4.0 swap
    Sounds like a short to ground some where? Start chasing wires from heater switch back. Also look for melted wires at the resistor plug. I would also check the wires behind the dash just behind the control switch. I would be surprised if there are not melted bare wires there.

    As for your other problems, they all sound like ground problems. Start with the easiest solution 1st and see if it solves your problems. That would be cleaning and checking grounds at block, frame, tub and starter and battery and lets see what ya find. No matter what the buzzing is not a good thing, you need to find this bare wire/short asap.
     
To Top