1. Welcome to Jeeps.net!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Jeep discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Jeep owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Wont start, starter spins like crazy oil light on

Discussion in 'Liberty' started by Jhogue08, Jul 13, 2019 at 6:06 PM.

  1. Jul 13, 2019 at 6:06 PM
    #1
    Jhogue08

    Jhogue08 [OP] New Member

    Joined:
    Saturday
    Member:
    #3517
    Messages:
    3
    Gender:
    Male
    06 liberty sport. 3.7 RWD

    Been fighting this since the end of March. Try to crank it, spins like hell wont start. Oil light is on but symptoms of bad fuel pump. I didnt hear the fuel pump hum had the fuel pump replaced. Same prob sent back to the shop. Replaced o2 sensor, and said there was a fuel leak in one of the lines. It would crank run for a few shut off and few minutes later it would crank again. Keep having the same issue. Picked it up from the shop yesterday. Drove about 100miles no prob. Wife took it to Walmart today came out wont start again. Oil light on and spinning like crazy. I'm at my wits ends ready to light a match
     
  2. Jul 14, 2019 at 5:52 AM
    #2
    Awrench

    Awrench Well-Known Member

    Joined:
    May 12, 2018
    Member:
    #2303
    Messages:
    501
    Gender:
    Male
    Vehicle:
    3 jeeps
    help me understand -

    Turning key to start - IT spins like crazy?
    What spins, just the starter OR the engine is spinning?
    What is your skill level and tool available?
    1) competent Skilled B) DIYer change a flat 3) where does the gas go


    Try the computer code check
    https://www.youtube.com/watch?v=_Ey98NHFrIA

    Is the check engine light (CEL) on ?
    Does the CEL come on at every start for about 3seconds*?


    * Yes it does not start every attempt to start, every time key moved to run/start position?
     
  3. Jul 14, 2019 at 1:02 PM
    #3
    Jhogue08

    Jhogue08 [OP] New Member

    Joined:
    Saturday
    Member:
    #3517
    Messages:
    3
    Gender:
    Male
    The motor is spinning but not firing. I was a service manager for a shop dont have any certifications though. All this I've been dealing with has been through a shop. They cant figure this out.

    Started out all the symptoms of a fuel pump had it towed they replaced the fuel pump week or so later I was driving the motor just shut off oil light came on motor would spin with no fire.

    Sent it back, replaced o2 sensor, and the fuel line right on top of the motor it had a leak, between a potential defective fuel pump and the leak that caused the break down

    3rd trip back to the shop. It dodnt make it a couple of days. Went to church came out a couple hrs later oil light on and motor spinning-no fire they say they went through like 3 diff fuel pumps same place they had ordered the original so they got another one from a diff supplier and replaced the connector/pig tail thinking that all the swapping in and out messed up the connector.

    Picked it up yesterday drove roughly a hundred miles. My wife went to Walmart and same exact symptoms
     
  4. Jul 14, 2019 at 1:51 PM
    #4
    bongo

    bongo Member

    Joined:
    Jul 7, 2019
    Member:
    #3481
    Messages:
    7
    Gender:
    Male
    First Name:
    buckwheat
    Vehicle:
    96&98&2011 jeeps
    4BT Diesel in 97 TJ, Totaled 2011 Wrangler rebuilt, painted and lifted.
    When I've broken a timing chain my engine will spun like crazy too.
     
  5. Jul 14, 2019 at 2:12 PM
    #5
    Jhogue08

    Jhogue08 [OP] New Member

    Joined:
    Saturday
    Member:
    #3517
    Messages:
    3
    Gender:
    Male
    That's the thing though Bongo it for intermittently it will crank run and drive and when it does it runs like a champ just there is something that is cutting power to the fuel pump or whatever the hell is wrong with it
     
  6. Jul 14, 2019 at 2:31 PM
    #6
    bongo

    bongo Member

    Joined:
    Jul 7, 2019
    Member:
    #3481
    Messages:
    7
    Gender:
    Male
    First Name:
    buckwheat
    Vehicle:
    96&98&2011 jeeps
    4BT Diesel in 97 TJ, Totaled 2011 Wrangler rebuilt, painted and lifted.
    When copper skyrocketed in price manufacturers started using some steel wires or less than pure copper wires meaning susceptibility to vibration cracking causing intermittent failures until circuit is wiggled and connection is remade. Circuit verification to components is a must. Fuel pump relay check is a must. If your unit has a battery temperature sensor under the battery check it and the circuit/connector to it. I've seen corrosion in the connector and up the wire under the insulation causing high resistance.
     
  7. Jul 14, 2019 at 2:45 PM
    #7
    Awrench

    Awrench Well-Known Member

    Joined:
    May 12, 2018
    Member:
    #2303
    Messages:
    501
    Gender:
    Male
    Vehicle:
    3 jeeps
    ideally a professional scanner, look at codes, and live data, a fuel pressure test as there is NO sensor for fuel pressure.
    When it is not starting spray some carb cleaner into TB - did the engine fire and try to start on the spray? this is a fast easy fuel test - the spray acts as a substitute for fuel.

    A noid light would confirm inj pulse.


    The oil light being on I would suspect some code related to that.
     

Products Discussed in

To Top